Bug #20

Line numbers in file annotation are not in sync with the actual lines.

Added by Elbin Pallimalil over 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:2012-05-23
Priority:HighDue date:
Assignee:Cristian Tibirna% Done:

100%

Category:-
Target version:2.9 Featurette

Description

https://bugzilla.redhat.com/show_bug.cgi?id=823176

Description of problem:
Please refer the attached screen shot. When viewing a file the line numbers in the file annotation section are not in sync with the actual line numbers. For eg in the screen shot, line number 15 is shown against what is actually line number 16.

Version-Release number of selected component (if applicable):
2.3

qgit.png - Screenshot (310 KB) Elbin Pallimalil, 2012-05-23 02:34

Associated revisions

Revision 6e4ce58e
Added by Cristian Tibirna over 5 years ago

fix issue #20 (line numbers in file view were misaligned)

History

#1 Updated by Elbin Pallimalil over 5 years ago

Additional info from Jim Lieb https://bugzilla.redhat.com/show_bug.cgi?id=823176#c4

I’ve tried all the combos of monospace fonts I could find. It is not an issue of fonts setup. The problem is in how the file display and file annotation is set up. Choosing a magic font “works” only if the font metrics are somehow identical with all font features. The annotations and line numbers are in a shaded (grey) font and the file itself is black. Whatever goes on in the rendering of each whether it is rounding errors, aliasing funnies or ??? getting the right magic is just dumb luck.

To show how bad it is off, If I display a 1233 line file, that last line is somewhere between lines 1164 and 1165 in the annotations/line numbers column. This makes this very useful feature (nicer than gitk et al) useless.

This feature needs to be re-thought. What needs to be done is to replace this canvas, text box, or whatever widget it is with a “table”. I may not be using the right terms but this pane has to be a two/three column, N row table. The rendering will then be rendering cells and who cares what the font characteristics are.

#2 Updated by Cristian Tibirna over 5 years ago

  • Assignee set to Cristian Tibirna
  • Priority changed from Normal to High
  • Target version set to 2.9 Featurette

#3 Updated by Cristian Tibirna over 5 years ago

  • Status changed from New to Resolved

Fixed with 6e4ce58e3. Thanks again for reporting, sorry for the long delay.

#4 Updated by Cristian Tibirna almost 5 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF